Unmet dependency with deb package

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Unmet dependency with deb package

WingIDE - User mailing list
Hi,

on Debian Jessie, I installed Wing debian package with dpkg -i but subsequently apt-get complains about unmet dependencies:

 wingide5 : Depends: libqt4-script (>= 4:4.5.3) but it is not going to be installed
            Depends: libqt4-sql (>= 4:4.6.1) but it is not going to be installed

This is easy to fix with: apt-get -f install but just to let you know.

Best wishes,

Luc J. Bourhis


_________________________________________________
Wing IDE users list
http://wingware.com/lists/wingide
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unmet dependency with deb package

WingIDE - User mailing list
Luc Bourhis via wingide-users wrote:
> on Debian Jessie, I installed Wing debian package with dpkg -i but
> subsequently apt-get complains about unmet dependencies:
>
>  wingide5 : Depends: libqt4-script (>= 4:4.5.3) but it is not going to
> be installed
>             Depends: libqt4-sql (>= 4:4.6.1) but it is not going to be
> installed
>
> This is easy to fix with: apt-get -f install but just to let you know.

Thanks for pointing this out.  We did try to remove all dependencies on
qt4 in Wing 5.1.10 since some of the package names have changed on some
distributions and Wing can run without them (it contains its own Qt4 to
fall back on).  But apparently Debian is still outsmarting us.

--

Stephan Deibel
Wingware | Python IDE

The Intelligent Development Environment for Python Programmers

wingware.com


_________________________________________________
Wing IDE users list
http://wingware.com/lists/wingide
Loading...