Exception using tests

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Exception using tests

WingIDE - User mailing list
Hi,

I am getting the following exception when I try to run a test.

I am on 5.1.7.1 and in the past had no problems with theses tests, I can
also run the test by clicking the 'green right' arrow.

The error happens when I select "Run Tests" on the Testing tab, tests
where added "Add Current File" option on the test menu.

Werner

File "C:\Program Files (x86)\Wing IDE
5.1\src\testing\runners\run_unittests_xml.py", line 149, in RunInSingleDir
   unittest.TestProgram(argv=argv, module=None, testRunner=runner)
File "C:\Python34\Lib\unittest\main.py", line 92, in __init__
   self.parseArgs(argv)
File "C:\Python34\Lib\unittest\main.py", line 139, in parseArgs
   self.createTests()
File "C:\Python34\Lib\unittest\main.py", line 146, in createTests
   self.module)
File "C:\Python34\Lib\unittest\loader.py", line 146, in loadTestsFromNames
   suites = [self.loadTestsFromName(name, module) for name in names]
File "C:\Python34\Lib\unittest\loader.py", line 146, in <listcomp>
   suites = [self.loadTestsFromName(name, module) for name in names]
File "C:\Python34\Lib\unittest\loader.py", line 114, in loadTestsFromName
   parent, obj = obj, getattr(obj, part)

AttributeError: 'module' object has no attribute 'test_lib_floatcanvas_bbox'
_________________________________________________
Wing IDE users list
http://wingware.com/lists/wingide
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Exception using tests

WingIDE - User mailing list
On 9/18/15 12:13 PM, Werner via wingide-users wrote:
> Hi,
>
> I am getting the following exception when I try to run a test.
>
> I am on 5.1.7.1 and in the past had no problems with theses tests, I can
> also run the test by clicking the 'green right' arrow.
>
> The error happens when I select "Run Tests" on the Testing tab, tests
> where added "Add Current File" option on the test menu.

I think the IDE is specifying a name of a test to be run and the test
doesn't exist.  Could you try selecting the file and running the tests
in that file?

Thanks,

John

_________________________________________________
Wing IDE users list
http://wingware.com/lists/wingide
Loading...